PAT--甲 1025 PAT Ranking

甲 1025 PAT Ranking (题解)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

输入格式:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

输出格式:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

1
registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

输入样例:

1
2
3
4
5
6
7
8
9
10
11
12
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

输出样例:

1
2
3
4
5
6
7
8
9
10
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题意:

有N个考场,每个考场有若干数量的学生,现在给出各个考场的准考证号与分数,要求将所有考生按分数从高到低排序,并按顺序输出所有考生的准考证号、排名、考场号以及考场内的排名。

思路:

1.用结构体存储学号和分数,考场号,考场内排名。

2.分别输入每个考场的学生的学号和分数,在考场内进行排序和存储。

3.所有考生整体排序输出。

我的代码如下:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct student
{
char id[15];
int score;
int group;
int rank;
}stu[30010];
bool cmp(student a,student b)//cmp函数编写排序规则,分数从高到低,分数相同则按学号逆序.
{
if(a.score!=b.score)
return a.score>b.score;
else
return (strcmp(a.id,b.id)<0);
}
int main()
{
int N,k,num=0;
scanf("%d",&N);
for(int i=1;i<=N;i++)
{
scanf("%d",&k);
for(int j=0;j<k;j++)
{
scanf("%s %d",stu[num].id,&stu[num].score);
stu[num].group=i; //记录考场号
num++;
}
sort(stu+num-k,stu+num,cmp); //考场内进行排序
stu[num-k].rank=1; //存储考场内学生的排名
for(int j=num-k+1;j<num;j++)
{
if(stu[j].score==stu[j-1].score)
stu[j].rank=stu[j-1].rank;//完全等于前面学生的分数 排名相同
else
stu[j].rank=j+1-num+k;
}
}
printf("%d\n",num);
sort(stu,stu+num,cmp); //所有考生进行排序
int r=1;
for(int i=0;i<num;i++)
{
if(i>0 && stu[i].score!=stu[i-1].score)//记录排名
r=i+1;
printf("%s %d %d %d\n",stu[i].id,r,stu[i].group,stu[i].rank);
}
return 0;
}
小礼物走一个哟
0%